Resolved
The issue causing degraded performance in the UI has been fully resolved. The platform is operating normally.
We appreciate your patience while we worked to address this issue.
Investigating
We are currently investigating an issue causing degraded performance in the UI. Some users may experience slow page loads and delayed responses when navigating the platform.